Go Back   Honda Accord Forum - Honda Accord Enthusiast Forums > General > General Tech Help
Sign in using an external account
Register Forgot Password?
Search

Welcome to the Honda Accord Forum - Honda Accord Enthusiast Forums.
If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-17-2011, 03:18 PM
 
Join Date: Aug 2011
Posts: 5
Default 96 accord turn signals not working?

I accidentally posted in the other section when I wanted to post here.

Both my turn signals just suddenly stopped working. They do not show up on the outside of the car, or blink on the inside of the car. But i DO hear the clicking when i engage the turn signal and turn the wheel a bit.

I checked the 7.5a fuses underneath the dash, those are fine. I replaced my whole turn signal assembly last year, so i suspect that It cant be that...

My hazards work fine though...


Would love some help!

Dustin
This ad is not displayed to registered members.
Register your free account today and become a member on Honda Accord Forum!
Reply With Quote
  #2  
Old 08-17-2011, 03:49 PM
 
Join Date: Aug 2011
Posts: 5
Default

I was told that it is most likely the turn signal flasher that has gone bad... But I have also read that the hazard and the turn signal share the same flasher... so that cant be the problem since my hazards work just fine... am i wrong?
Reply With Quote
  #3  
Old 08-17-2011, 04:51 PM
Super Moderator
2005 Acura TSX
 
Join Date: Sep 2006
Location: Houston, TX
Posts: 10,614
Default

That is correct, the relay is working if the hazards work.

There are some electrical tests you can try. You can pry out the hazard switch and test the electrical connector. The yellow wire has 12V to ground (any bare metal bolt should work for a ground) with the key in the II position.
__________________
2005 Acura TSX MT
Reply With Quote
  #4  
Old 08-17-2011, 04:52 PM
Super Moderator
2005 Acura TSX
 
Join Date: Sep 2006
Location: Houston, TX
Posts: 10,614
Default

Oops, that wire would be the yel/wht wire.
__________________
2005 Acura TSX MT
Reply With Quote
Old 08-17-2011, 04:52 PM
 
 
 
Reply

Tags
06, 1996, 96, accord, arent, blinkers, clicking, honda, problems, signal, signals, stopped, turn, turning, working


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 06:40 PM.

Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.


Honda and the Honda marquee are registered trademarks of the American Honda Motor Company, Inc. Neither American Honda Motor Company nor its subsidiaries or affiliates shall bear any responsibility for HondaAccordforum.com content, comments, or advertising. HondaAccordforum.com is not affiliated with American Honda Motor Company in any way. American Honda Motor Company does not sponsor, support, or endorse HondaAccordforum.com in any way. Copyright/trademark/sales mark infringements are not intended or implied.

Emails Backup