Go Back   Honda Accord Forum - Honda Accord Enthusiast Forums > General > General Tech Help
Sign in using an external account
Register Forgot Password?
Search

Welcome to the Honda Accord Forum - Honda Accord Enthusiast Forums.
If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-15-2010, 03:01 PM
 
Join Date: Dec 2009
Posts: 6
Default CEL Code P1456 problem after a fix 2 yrs ago.

I posted this same problem 2 years ago right after the car passed Virginia Emissions.
The CEL came ON a week ago , two weeks after I took the car for Virginia emissions. I read the code and it came up [P1456] again, so I cleared it. It came back again, so I bought a new Gas cap and didn't reset the code to see if the Gas cap fixes the problem.

From what I have read, the Gas cap and the Evap Cannister are the most common problems, but doen't the Cannister problem throws P1457, not P1456?

Both times, the ECL came on after the Emission test, so could the Emission triggers this problem?

I know that 2 years ago when I posted about this, JimBlake was kind enough to give me some scenarios as to what the problem could be. Is P1456 code 95% related to a loose/damaged/or work gas cap ( gasket)?

The new gas cap looks black compared to the old gray one I had. Maybe this cap fixes the problem?

Thanks for any comments and thanks in advance for your time,
-Mott

2002 Accord EX-L 5 speed 187K miles
This ad is not displayed to registered members.
Register your free account today and become a member on Honda Accord Forum!
Reply With Quote
  #2  
Old 05-15-2010, 05:42 PM
hondadude's Avatar
Super Moderator
 
Join Date: Aug 2006
Location: Fayetteville, AR
Posts: 2,168
Default

Search is your Friend

98-00 Accord Evap Codes P1456 & P1457
__________________
93 Yota T-100 155k miles. 3.0 "born to die" engine
92 Acura Legend 135k miles. Wife lets me drive it for oil changes.
The one eyed Mechanic says "The fluid is low"; The two eyed Technician says "WHY is the fluid low?"
Been There, Done That, Read the Book, Seen the Movie, Got the T-shirt
http://www.righttorepair.org/
Reply With Quote
  #3  
Old 05-15-2010, 10:04 PM
JimBlake's Avatar
Super Moderator
 
Join Date: May 2006
Location: Ohio
Posts: 15,683
Default

Right, P1456 = tank
P1457 = canister

Either one means it's not airtight like it should be. Gas cap is mentioned in the owner's manual just because that's the only thing that Honda thinks a clueless driver can fix by himself.

Other things that can cause a fuel tank to leak...
Bad gasket where the fuel pump mounts into the top of the tank.
Bad gasket where the fuel gauge sender mounts.
Any of about a dozen rubber vacuum hoses up there & around the fuel filler neck.
I guess the tank itself might leak, but then you'd probably smell gasoline.

(The link that HondaDude provided is real good too)
__________________
'05 Saab 9x aero (RIP)
'09 Saab 9ss
'10 Saab 9sc
my kids have Civics
Reply With Quote
  #4  
Old 05-16-2010, 03:18 PM
 
Join Date: Dec 2009
Posts: 6
Default

Thanks [JimBlake] for your time. The link that HondaDude posted pertains to Accords 98 to 00, so it doesn't include 2002.

Could the Emission test had anything to do with the CEL since it came on right after the car passed emissions both times?

If the new gas cap doesn't fix the problem, do you know roughly how much it will cost to fix, assuming its the other stuff you listed.

The only thing I noticed is when I start the car the rpms go to 1200-1400 , but after the car warms they go down to 800 ( in neutral), so not sure if this is related. The throttle body has been cleaned and I put bg44K every 12k miles.

Thanks
-M
Reply With Quote
  #5  
Old 05-16-2010, 03:21 PM
1998 Honda Accord
 
Join Date: May 2010
Posts: 3
Default

This powerpoint explains which evap systems problems trigger a P1456 code and which trigger a P1457:

http://www.asaillinois.org/09CAN/AsianEvap_1009CAN.pdf
Reply With Quote
  #6  
Old 05-16-2010, 10:23 PM
JimBlake's Avatar
Super Moderator
 
Join Date: May 2006
Location: Ohio
Posts: 15,683
Default

1998 to 2002 are about the same for the EVAP system.
__________________
'05 Saab 9x aero (RIP)
'09 Saab 9ss
'10 Saab 9sc
my kids have Civics
Reply With Quote
  #7  
Old 05-17-2010, 09:31 AM
 
Join Date: Dec 2009
Posts: 6
Default

UPDATE:
This morning, on my way to work the CEL went off, so I assume the Gas Cap was the culprit.


just wanted to thank people who have responded. I'll keep an eye on this problem. Just glad I didn't have to take it for repairs.

regards,
-Mott
Reply With Quote
Old 05-17-2010, 09:31 AM
 
 
 
Reply

Tags
1456, 1998, 98, accord, cap, car, code, emission, forum, gas, honda, p1456, problem, problems, repair


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 12:08 AM.

Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.


Honda and the Honda marquee are registered trademarks of the American Honda Motor Company, Inc. Neither American Honda Motor Company nor its subsidiaries or affiliates shall bear any responsibility for HondaAccordforum.com content, comments, or advertising. HondaAccordforum.com is not affiliated with American Honda Motor Company in any way. American Honda Motor Company does not sponsor, support, or endorse HondaAccordforum.com in any way. Copyright/trademark/sales mark infringements are not intended or implied.

Emails Backup