Go Back   Honda Accord Forum - Honda Accord Enthusiast Forums > General > General Tech Help
Sign in using an external account
Register Forgot Password?
Search

Welcome to the Honda Accord Forum - Honda Accord Enthusiast Forums.
If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-17-2009, 11:26 AM
Newest Of Newbies
 
Join Date: Jun 2009
Location: rocktucky, il
Posts: 25
Send a message via AIM to forestcd6
Default help!!!!!!!speedometer not working

i just recently bought a 95 accord ex 4 door and i realized that the speedometer isnt working.. was curious of the reasons why it may not be working have never had the issue with other cars i have had??? could it the VSS or something different??? if it is the VSS where is that located and whats the easiest way to replace this??? any insite would be greatly appreciated
thanks
This ad is not displayed to registered members.
Register your free account today and become a member on Honda Accord Forum!
Reply With Quote
  #2  
Old 06-17-2009, 12:14 PM
JimBlake's Avatar
Super Moderator
 
Join Date: May 2006
Location: Ohio
Posts: 15,681
Default

The VSS is on the tranny, kinda below the thermostat, in the box labeled E-6.
#2 is the speedometer gear & #1 is the holder for that gear.
Click the image to open in full size.

Does the cruise-control work?
Does the check-engine light work (bulb check when you first turn on the key)?
Does the check-engine light come on when driving?

Cruise-control uses the VSS so if that works the VSS is OK.
ECU watches the VSS, so a bad VSS would set off a CEL.

If the other stuff is OK, then you're left with bad connections at the back of the cluster (or wiring between).
__________________
'05 Saab 9x aero (RIP)
'09 Saab 9ss
'10 Saab 9sc
my kids have Civics

Last edited by JimBlake; 06-17-2009 at 12:28 PM.
Reply With Quote
  #3  
Old 06-17-2009, 03:06 PM
00AccordLX5spd's Avatar
Registered User
 
Join Date: Jan 2007
Location: Brandon, MS
Posts: 4,322
Default

Does the entire cluster not work (i.e. tach, speedometer, gas gauge, temp gauge) or is it just the speedometer?
As Jimblake said if the cruise control works it is not the VSS.
__________________
2000 Accord LX Sedan F23A1 5spd
2009 Ford Edge SEL (wife's car)
Reply With Quote
  #4  
Old 06-18-2009, 12:07 PM
Newest Of Newbies
 
Join Date: Jun 2009
Location: rocktucky, il
Posts: 25
Send a message via AIM to forestcd6
Default

the cluster works fine except the mph, cruise is fine, no throwing any CEL, when car is turned off the mph jumps to between 40-50 than goes back down to 0... ill check the cluster this weekend to see if the wiring is loose and if nothing else ill take take it to honda to have it looked at????
Reply With Quote
  #5  
Old 06-18-2009, 12:15 PM
00AccordLX5spd's Avatar
Registered User
 
Join Date: Jan 2007
Location: Brandon, MS
Posts: 4,322
Default

Likely it is the speedometer itself. I would NOT take it to a dealership. they will just throw in a new cluster with 0 miles on it and charge you enough money that you will have to sell the fillings out of your teeth in order to pay for it. Then they will probably tell you that a bunch of other stuff is not working right and before you know it they will be trying to charge you more than the car is worth. I think they do this to try to convince you that you need to trade your car in to them and buy a new one from their dealership.

Here are a few options:

1) Find a speedometer repair shop locally and get a price quote.

2) Find a speedometer repair shop on the internet, pull the cluster, and ship it to them. I think you can get it done that way for around $100.

3) Find another cluster from a junkyard and hope it works.

4) Look on eBay and find one. Many sellers will even roll the mileage to whatever you want it to say - so you could swap out clusters and the mileage reading would still be fairly accurate. When I was searching eBay I was finding them in the $40-$50 range. I was going to swap mine out, but decided it was time for a new car and didn't feel like hassling with it.
__________________
2000 Accord LX Sedan F23A1 5spd
2009 Ford Edge SEL (wife's car)
Reply With Quote
  #6  
Old 06-18-2009, 12:34 PM
JimBlake's Avatar
Super Moderator
 
Join Date: May 2006
Location: Ohio
Posts: 15,681
Default

Working cruise means the VSS is good. At some point the signal from the VSS splits off for the cruise and for the ECU. Somewhere "downstream" after those split off, the signal gets lost.

Wouldn't hurt to check for loose wiring in the connector at the back of the cluster.
__________________
'05 Saab 9x aero (RIP)
'09 Saab 9ss
'10 Saab 9sc
my kids have Civics
Reply With Quote
  #7  
Old 06-18-2009, 02:59 PM
Junior Member
 
Join Date: Feb 2009
Location: Morrisville, PA
Posts: 41
Default

If I had to guess that will be a pretty spendy repair since you will probably have to buy a whole new gauge cluster. The speedo is integrated into the cluster and is most likely not sold from Honda as a separate part. You would be a lot better off going to a junk yard or buying a used cluster off e-bay. The miles will not match but if you have some basic mechanical skills, replacing a gauge cluster is not that hard just requires a phillips head screw driver and some time. I replaced the cluster on my 89' in less then an hour, pretty much "plug and play".
Reply With Quote
  #8  
Old 06-18-2009, 04:11 PM
Newest Of Newbies
 
Join Date: Jun 2009
Location: rocktucky, il
Posts: 25
Send a message via AIM to forestcd6
Default

just called a junk yard and am goin to buy a cluster for like $65 hopefully that fixes the issue if not ill let you all know
thanks for all the help k guys
Reply With Quote
  #9  
Old 06-18-2009, 04:33 PM
00AccordLX5spd's Avatar
Registered User
 
Join Date: Jan 2007
Location: Brandon, MS
Posts: 4,322
Default

That's a better deal than I could find on eBay when I just searched. Dang these things have gone up. They are running anywhere from $79.00 to $149.99 now.
__________________
2000 Accord LX Sedan F23A1 5spd
2009 Ford Edge SEL (wife's car)
Reply With Quote
  #10  
Old 06-18-2009, 08:16 PM
Newest Of Newbies
 
Join Date: Jun 2009
Location: rocktucky, il
Posts: 25
Send a message via AIM to forestcd6
Default

does anybody know if it has to be model specific or no???? went to go and get it and was a lx and was told that it has to be model specific or it wouldnt work
Reply With Quote
Old 06-18-2009, 08:16 PM
 
 
 
Reply

Tags
1994, 2000, 89, 95, accord, broken, cluster, control, cruise, gauge, honda, repairs, speedometer, working, works


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 04:20 PM.

Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.


Honda and the Honda marquee are registered trademarks of the American Honda Motor Company, Inc. Neither American Honda Motor Company nor its subsidiaries or affiliates shall bear any responsibility for HondaAccordforum.com content, comments, or advertising. HondaAccordforum.com is not affiliated with American Honda Motor Company in any way. American Honda Motor Company does not sponsor, support, or endorse HondaAccordforum.com in any way. Copyright/trademark/sales mark infringements are not intended or implied.

Emails Backup