No instrument cluster light ? - Honda Accord Forum - Honda Accord Enthusiast Forums


Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-19-2010, 08:37 PM
Senior Member
Thread Starter
 
Join Date: Aug 2010
Location: MA
Posts: 526
Question No instrument cluster light ?

No instrument cluster light at all. All other lights working just fine. Found a blown fuse for cluster/back up lights in the left side kick panel fuse box. Replace it with the same rating 7.5 amp, but still no cluster light, back up lights working fine. What could it be ? Dimmer switch maybe ? Where is it and how to check ? Thanx guys
It's a 99 LX 5sp.

Last edited by piggylover1985; 08-22-2010 at 06:38 PM.
Reply With Quote
  #2  
Old 08-20-2010, 06:46 PM
poorman212's Avatar
Super Moderator
 
Join Date: May 2010
Location: Youngsville, NC
Posts: 11,397
Default

Not sure of the year, there are links in the DIY section to wire diagrams and manuals. I'd get those, for your year/model and it should help you in testing the dash dimmer switch.
Reply With Quote
  #3  
Old 08-22-2010, 01:14 PM
Senior Member
Thread Starter
 
Join Date: Aug 2010
Location: MA
Posts: 526
Default

Quote:
Originally Posted by poorman212 View Post
Not sure of the year, there are links in the DIY section to wire diagrams and manuals. I'd get those, for your year/model and it should help you in testing the dash dimmer switch.
I tried the search but can't seem to find the wiring diagrams for the cluster light. It's wierd because all other light are working okay. Clock, radio, interior, vanity lights all working. I don't want to just probing the harness with a test light and find out i accidently deploy the airbags or something you know.
Reply With Quote
  #4  
Old 08-22-2010, 01:37 PM
poorman212's Avatar
Super Moderator
 
Join Date: May 2010
Location: Youngsville, NC
Posts: 11,397
Default

What year are we working with, everything is a guess without knowing what year/mdoel. Is the fuse still good or did it blow.
Reply With Quote
  #5  
Old 08-22-2010, 06:38 PM
Senior Member
Thread Starter
 
Join Date: Aug 2010
Location: MA
Posts: 526
Default

Quote:
Originally Posted by poorman212 View Post
What year are we working with, everything is a guess without knowing what year/mdoel. Is the fuse still good or did it blow.
Sorry, it's a 99 LX 5sp.
Reply With Quote
  #6  
Old 08-23-2010, 06:14 PM
Senior Member
Thread Starter
 
Join Date: Aug 2010
Location: MA
Posts: 526
Default

I checked the dimmer switch with an ohm meter at the connector, the resistance increase as i turn the dimmer to the right close to 20,000 ohms, so i think the dimmer switch is good. What else should i check for, seems like the black wire at the same connector has good ground also.

Last edited by piggylover1985; 08-24-2010 at 05:43 PM.
Reply With Quote
  #7  
Old 08-25-2010, 09:13 PM
Senior Member
Thread Starter
 
Join Date: Aug 2010
Location: MA
Posts: 526
Default

Any ideas guys ? I also checked all the bulbs, there were a few bunt out, i replace them with good used ones, but still no luck.
Reply With Quote
  #8  
Old 08-25-2010, 09:31 PM
 
Join Date: Aug 2010
Posts: 2
Default

hi there im not to sure how to post a new thred n im having a similar problem so i thot id reply my dash lights are out n its not the fuse as well as my tail lights have just went out n it not the fuse or bulbs. Any ideas or info would be much appriciated thanx.
Reply With Quote
  #9  
Old 08-26-2010, 05:38 PM
Senior Member
Thread Starter
 
Join Date: Aug 2010
Location: MA
Posts: 526
Default

Quote:
Originally Posted by trevor_o View Post
hi there im not to sure how to post a new thred n im having a similar problem so i thot id reply my dash lights are out n its not the fuse as well as my tail lights have just went out n it not the fuse or bulbs. Any ideas or info would be much appriciated thanx.
Did they goes out the same time ? My tail lights are working fine. The only thing not light up is the cluster, climate control lights and radio lights, just won't illuminate at night at all. I suspect the multiplex is the bad guy, but not sure of how to check it.
Reply With Quote
  #10  
Old 08-26-2010, 07:20 PM
 
Join Date: Aug 2010
Posts: 2
Default

no they went at different times. so i dont think they are a connected problem. what is a multiplex n would it be on a 98?
yeah same every thing else lights up but the cluster.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Light bulbs on instrument cluster, 98 accord Nebbb_98 General Tech Help 0 09-04-2008 06:11 PM
Instrument cluster 94 Accord LX CougarMark67XR7 Private 'Wanted' Classifieds 1 12-24-2007 02:08 AM
How to change bulb in Instrument Cluster Bernman General Tech Help 9 03-18-2007 04:52 PM
How to change 92 accord instrument cluster? imnoweirdo Appearance 0 01-29-2007 06:49 PM
pod cluster for instrument cluster marbro Appearance 5 05-20-2006 11:13 PM


Tags
89, 95, 99, accord, accordfuse, dimmer, driver, forum, good, honda, instrument, light, lights, vanity, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 06:32 PM.