Go Back   Honda Accord Forum - Honda Accord Enthusiast Forums > General > General Tech Help
Sign in using an external account
Register Forgot Password?
Search

Welcome to the Honda Accord Forum - Honda Accord Enthusiast Forums.
If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-28-2007, 09:49 AM
 
Join Date: Mar 2007
Location:
Posts: 12
Default speed sensor problems (vss) 94 accord dx

I am getting a check engine light (cel) and the code is 17 (vss) the wierd thing is that my tach and speedo is perfectly fine. they work exactly the way they are supposed to. This code just popped up 2 days ago. I checked the plug on the sensor and the wires are getting the correct ohms and continuity. My cruise control unit on this car is not there. the previous owner took it out for some reason. would that affect it, i know they are some what linked?? I have been driving this car for about a year and this code just popped up. The had been a map sensor code light on for a while and I finally fixed that. The pin on the computer was loose. as soon as I fixed that map code , the car ran so much better but now the vss code is up. it does not seem to affect anything. what could be the problem? if the sensor it self was bad would'nt my tach not work or jump around all crazy?
This ad is not displayed to registered members.
Register your free account today and become a member on Honda Accord Forum!
__________________
94 accord 4dr. sohc f-22b2
Reply With Quote
  #2  
Old 11-28-2007, 09:54 AM
 
Join Date: Mar 2007
Location:
Posts: 12
Default RE: speed sensor problems (vss) 94 accord dx

Could it have somthing to do with my oil pressure switch?
__________________
94 accord 4dr. sohc f-22b2
Reply With Quote
  #3  
Old 11-28-2007, 10:18 AM
JimBlake's Avatar
Super Moderator
 
Join Date: May 2006
Location: Ohio
Posts: 15,518
Default RE: speed sensor problems (vss) 94 accord dx

I bet it's not related to your oil pressure switch, as that doesn't even go to the ECU.

Check the VSS pin on the ECU plug, since you already had that problem with the MAP sensor.

I think in '94 the VSS signal goes both to the speedo and to the ECU (but not the tach). It's possible for the wire to the speedometer to be good while the plug at the ECU is loose/bent/dirty.
__________________
'05 Saab 9x aero (RIP)
2 '07 Civics
'09 Saab 9ss
'10 Saab 9sc
Reply With Quote
  #4  
Old 11-28-2007, 10:37 AM
 
Join Date: Mar 2007
Location:
Posts: 12
Default RE: speed sensor problems (vss) 94 accord dx

I have already checked the ecu pin, its ok. also the 3p connector is receiving the correct voltages. yellow wire is reading the same as the battery voltage, the orange wire is reading 5 volts and the black is coninuity to ground. also my speedo works perfectly fine. I can't figure out where the problem lies?? The cel will turn off when i turn the car off. it will come on when i am in gear and slowing down. Also if the cel has'nt popped on yet, when I jump the data port it will still flash the code 17,so even when the cel is not lit up it still throws the code??? any help is greatly appreciated. thanks in advance.
__________________
94 accord 4dr. sohc f-22b2
Reply With Quote
  #5  
Old 11-28-2007, 12:08 PM
Super Moderator
2005 Acura TSX
 
Join Date: Sep 2006
Location: Houston, TX
Posts: 10,593
Default RE: speed sensor problems (vss) 94 accord dx

You might want to reset the ECU by pulling the 7.5 amp radio fuse in the engine bay box for about thirty seconds. This will erase the code 17 stored in the ECU, then drive the car to see if the CEL comes back on.

In the DIY section, there is a thread called ACC 5th gen that has a link to a site that has the 94 shop manual as a pdf, but it sounds like you have done most of the diagnostic tests.
__________________
2005 Acura TSX MT
Reply With Quote
  #6  
Old 11-28-2007, 04:06 PM
 
Join Date: Mar 2007
Location:
Posts: 12
Default RE: speed sensor problems (vss) 94 accord dx

Yeah, I have already tried that as well and it does keep coming back on.???? Does anyone have a link fora digram for the pin and wire location for the ecu , I need somthing that describes the color of the wires, what the go to and the pin location. When I pull my back up fuse it will not reset the ecu for some reason. So I always have to disconnect the battery.
__________________
94 accord 4dr. sohc f-22b2
Reply With Quote
  #7  
Old 11-28-2007, 05:41 PM
Super Moderator
2005 Acura TSX
 
Join Date: Sep 2006
Location: Houston, TX
Posts: 10,593
Default RE: speed sensor problems (vss) 94 accord dx

The information is in that shop manual that I referenced in our DIY section (ACC 5th gen).

If you go to Fuel and Emissions and go to page 11-52, there are the two pins on the ECU for the VSS (A26 and B10). 11-15 has the description of the pin locations, but doesn't have wire colors (or I can't find them). I think that a26 is the ground.

My 95 CD has them. A26 is brown/black and B10 is orange.
__________________
2005 Acura TSX MT
Reply With Quote
  #8  
Old 11-29-2007, 09:32 AM
 
Join Date: Mar 2007
Location:
Posts: 12
Default RE: speed sensor problems (vss) 94 accord dx

thanks man, I appreciate it. I will check it out and let you guys know what happens. thanks again.
__________________
94 accord 4dr. sohc f-22b2
Reply With Quote
  #9  
Old 11-29-2007, 12:55 PM
TexasHonda's Avatar
Super Moderator : And A Texan
 
Join Date: Feb 2007
Location: Katy, TX
Posts: 7,871
Default RE: speed sensor problems (vss) 94 accord dx

I have seen code 17 pop up due to an intermittent VSS. It might happen so quickly you might not notice speedometer changes. A new VSS is <$25 on ebay. It's a simple piece of hardware to repalce also.

good luck
__________________
See you down the ROW
1994 Accord EX
2003 Acura MDX
2006 Acura TSX
Reply With Quote
Old 11-29-2007, 12:55 PM
 
 
 
Reply

Tags
5th, 94, 97, accord, bad, check, dx, engine, gen, honda, light, problems, sensor, speed, speedsensor, switch, symptoms, vss


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 08:09 AM.

Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.


Honda and the Honda marquee are registered trademarks of the American Honda Motor Company, Inc. Neither American Honda Motor Company nor its subsidiaries or affiliates shall bear any responsibility for HondaAccordforum.com content, comments, or advertising. HondaAccordforum.com is not affiliated with American Honda Motor Company in any way. American Honda Motor Company does not sponsor, support, or endorse HondaAccordforum.com in any way. Copyright/trademark/sales mark infringements are not intended or implied.

Emails Backup