Engine & Internal Chat about beefing up your engine's insides here.

k24 loss of power

  #1  
Old 04-24-2018, 09:48 AM
Senior Member Stereo Guru..Almost A Mod :)
Thread Starter
Join Date: Feb 2011
Location: louisiana
Posts: 862
Default k24 loss of power

I have an 05 accord with the 4cyl with a manual transmission. It seems that as of lately the car has a lag in power between about 1500 and 1800 rpms that I dont remember being there before.

It will start to pick up power again before the timing advances so I dont think I am confusing the pickup at 2300ish rpms and the extra pickup at 1800 rpms. Again I dont remember it doing this in the past.

The plugs have less than 5k miles on them and the air filter was changed at the same time. They are NGK LI plugs. It didnt start when I changed the plugs and filter. it was fine for a while afterwards and then started.

I can drive quite spirited and stay above 2k rpms and kind of avoid the problem but this is just my daily for the time being and so I try to optimize Gas mileage.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
1991AccordLX
Engine & Internal
1
07-25-2008 10:11 PM
Jreal
General Tech Help
2
03-27-2008 07:35 AM
Deatschwerks
Private 'Wanted' Classifieds
0
11-06-2007 03:38 PM
stefanb21487
Engine & Internal
8
06-02-2007 03:50 PM
legionofone
Engine & Internal
49
12-21-2006 10:53 AM


Thread Tools
Search this Thread
Quick Reply: k24 loss of power


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.