General Tech Help Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

Injectors

  #1  
Old 02-18-2019, 08:21 AM
TexomaAccord's Avatar
Senior Member
Thread Starter
Join Date: Mar 2014
Location: Texoma, Texas
Posts: 372
Default Injectors

Ugh okay so got the new thermos in, new fast thermo valve in, new upper rad hose on, new fan switch in and took her for a drive.. 97 accord 2.7..

drive drive drive... temps doing well.. I pull up to the house, check engine light starts flashing what in the world!!!???

p0301
p1399
Smoke coming from around cylinder 1.
I notice timing cover has popped out rubbing on power steering hose ( easy fix )
I look around pump because its still squealing because when I put new hose on I have air in the line, but notice it was wet behind it and smelled like gas. Pulled the cover off and gas is all over injector 1 and soaked all over top of engine. I ordered new seal kit, what a waste I'm sure, may as well replace injectors.. now when I go look at honda parts now, it's telling me for my car it's 06164-P0A-000 But when I run those numbers I'm coming up for a 1993 prelude si with a 2.3 .. same injectors??

06164-P0A-000



 
  #2  
Old 02-18-2019, 09:40 AM
Senior Member
Join Date: Jun 2017
Posts: 393
Default

That is the correct part number but they have been discontinued. To help you out the OEM is Keihin 155-0083.
 
  #3  
Old 03-20-2019, 10:47 AM
TexomaAccord's Avatar
Senior Member
Thread Starter
Join Date: Mar 2014
Location: Texoma, Texas
Posts: 372
Default

Ok installed new injector started driving it.. fine fine fine, stopped at a light.. cel started flashing.. pulled codes 301 and pending 1399...
 
  #4  
Old 03-20-2019, 10:56 AM
shipo's Avatar
Super Moderator
Join Date: Aug 2012
Location: Southern New Hampshire
Posts: 2,539
Default

Sorry to say it, but replacing injectors very rarely fixes anything. Yes, I know I've heard a lot of folks claim new injectors cures a whole host of problems, but I've never once seen it work.

My advice would be to get the engine professionally diagnosed.
 
  #5  
Old 03-20-2019, 11:53 AM
TexomaAccord's Avatar
Senior Member
Thread Starter
Join Date: Mar 2014
Location: Texoma, Texas
Posts: 372
Default

The injector on number 1 was leaking gas.. figured that was the issue
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
brownstreak
General Tech Help
10
06-29-2007 08:22 AM
curious126
Engine & Internal
2
02-03-2007 04:29 AM
fireballer44
General Tech Help
3
10-24-2006 09:30 PM
accordinprogress
Engine & Internal
3
12-07-2005 10:44 AM
accordinprogress
Engine & Internal
4
12-06-2005 12:30 PM


Thread Tools
Search this Thread
Quick Reply: Injectors


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.