Audio/Visual Electronics Wired up? Everyone's got some sort of electrical modification... let's hear about it here.

Audio/Visual Electronics not working

  #2  
Old 12-28-2008, 10:57 AM
WheelBrokerAng's Avatar
Administrator
Join Date: Aug 2004
Location: Canton/Massillon, Ohio 44646
Posts: 30,431
Default RE: Audio/Visual Electronics not working

Hi New Member:

Welcome to the forums..the links are not all working at this time..sorry about that..but the owners always say they are working on that..maybe they will get it fixed soon.

WheelBrokerAng [sm=americanasmiley.gif]
 
  #3  
Old 12-28-2008, 11:57 AM
t00fatt's Avatar
Been Around A Long Time Member
Join Date: Nov 2006
Location: Miami
Posts: 3,294
Default RE: Audio/Visual Electronics not working

There is no double DIN kit for the 7th gen, if you want to mount a double DIN you would have to custom fab it your self or pay someone to do it for you.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
electronics84
Audio/Visual Electronics
1
09-09-2009 02:07 PM
meb9796
New Member Area
0
12-28-2008 10:57 AM
vinc3stylez
Off Topic
0
09-07-2008 02:29 PM
kabhatti
General Tech Help
2
06-18-2007 08:25 PM
t00fatt
Audio/Visual Electronics
1
03-21-2007 04:24 PM


Thread Tools
Search this Thread
Quick Reply: Audio/Visual Electronics not working


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.