General Tech Help Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

Indicators

  #1  
Old 02-17-2019, 03:15 AM
Thread Starter
Join Date: Feb 2019
Posts: 3
Arrow Indicators

Hello everyone, I have a 2004 Accord estate 2.2 Diesel. Last weekend I hitched up to a trailer and plugged in the trailer lights, I have since found there was a short in the trailer wiring. My hazards work fine but if I turn on either indicator it flashes quickly (all bulbs working and no trailer plugged in), if i turn on the lights then the indicators work correctly. There is no fuses blown. Does this sound like the short has damaged the flasher relay it the indicator switch
 
  #2  
Old 02-17-2019, 12:46 PM
Been Around A Long Time Member
Join Date: Feb 2016
Location: Kimball MI
Posts: 1,052
Default

Originally Posted by Pebs View Post
Hello everyone, I have a 2004 Accord estate 2.2 Diesel. Last weekend I hitched up to a trailer and plugged in the trailer lights, I have since found there was a short in the trailer wiring. My hazards work fine but if I turn on either indicator it flashes quickly (all bulbs working and no trailer plugged in), if i turn on the lights then the indicators work correctly. There is no fuses blown. Does this sound like the short has damaged the flasher relay it the indicator switch
Quite possibly. Either that, or a heavy duty flasher relay was installed.
 
  #3  
Old 02-17-2019, 01:03 PM
Thread Starter
Join Date: Feb 2019
Posts: 3
Default

Everything was working normally (with or without a trailer) before I plugged in the trailer with a short in the wiring
 
  #4  
Old 02-17-2019, 08:34 PM
Super Moderator
Join Date: Sep 2006
Location: Houston, TX
Posts: 13,113
Default

The US accord uses the same relay for the hazards and turn signals (sounds like you call them indicators).

This is a tough call. The turn signal/hazard relay or maybe the MICU (multiplex integrated control unit). The wiring may have damaged as well, so do your best to inspect near where you connected the trailer.
If available, stop by an auto parts store to get your codes scanned.
 
  #5  
Old 02-18-2019, 01:27 AM
Thread Starter
Join Date: Feb 2019
Posts: 3
Default

I have checked the wiring from the socket to the trailer light control unit and the control unit itself and both seem ok. If I remove the Earth from the control unit I have no flasher at all on the car.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jinx
Engine & Internal
1
05-25-2012 09:59 AM
atom1
General Tech Help
1
10-07-2011 01:40 PM
Crue33
General Tech Help
2
05-26-2011 11:17 PM
Amtrak288
General Tech Help
4
06-09-2008 01:25 PM
mr happy
General Tech Help
1
09-14-2005 11:11 PM


Thread Tools
Search this Thread
Quick Reply: Indicators


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.