General Tech Help Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

sensor help

  #1  
Old 05-12-2011, 11:29 AM
Thread Starter
Join Date: Apr 2011
Posts: 5
Default sensor help

Hi i have a 1996 accord ex 2.2 lt vtec with a automatic transmission. Im getting error codes p0141 o2 sensor heater circut malfunction ( bank 1 sensor 2) where can i find this sensor?


I also have error code p0501 vehicle speed sensor A range/performance what is this and how can i fix it?

A few months ago my speedometer stopped working everything else on the cluster still works so i changed the speed sensor and the speedometer still doesnt work is there another sensor? Any advice on how to fix this?

Any advice would help Thanks
 
  #2  
Old 05-12-2011, 11:50 AM
TexasHonda's Avatar
Super Moderator : And A Texan
Join Date: Feb 2007
Location: Katy, TX
Posts: 9,651
Default

B1-S2 is the O2 sensor behind the catalyic converter.

Since you've replaced the VSS, you may have wiriing or connector damage causing loss of speedometer function. Are the odometers and cruise control not working? This would confirm the gauge panel is not getting a good VSS signal somehow.

Inspect wiring and connectors (trace wiring) and look for possible damage. You can disconnect from VSS and gauge panel and check individual wires and connections w/ VOM by shorting one end to ground and checking other end for ground. If ground is missing you've found the damaged or open wire.

If all looks OK, you can attach a voltage monitor to the VSS output and monitor for voltage outputs when wheel is rotated manually. It should show a on/off/on... voltage pulse of several volts.

good luck
 
  #3  
Old 05-12-2011, 11:15 PM
Thread Starter
Join Date: Apr 2011
Posts: 5
Default

Thanks for the info and quick response
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
choi
General Tech Help
7
04-18-2014 08:43 PM
pondrun
General Tech Help
29
01-12-2014 08:05 PM
dmost30
General Tech Help
2
09-08-2008 12:42 AM
dmost30
New Member Area
0
09-08-2008 12:42 AM
HORSEPOWERJUNKIE2007
General Tech Help
2
03-31-2008 04:53 PM


Thread Tools
Search this Thread
Quick Reply: sensor help


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.