Vehicle Speed Sensor Symptoms - Honda Accord Forum - Honda Accord Enthusiast Forums

General Tech Help Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

Vehicle Speed Sensor Symptoms

Reply

 
 
 
  #1  
Old 04-19-2014, 04:20 PM
Thread Starter
Join Date: Mar 2014
Location: Monmouth, Maine
Posts: 7
Default Vehicle Speed Sensor Symptoms

Hello. I know I need to replace the VSS, because my speedometer doesn't work half the time, sometimes it shoots up to 100 MPH while in park (idling) and the D4 light will start blinking. This is an off and on problem, but when the speedometer starts acting up and the D4 light starts blinking, the transmission shifts weird. It will down shift and slip and do all kinds of weird things. The car acts like it is running out of gas. It has loss of power and everything. Only while the speedometer stops working, and the D4 light starts blinking. Is it possible that the VSS failure can cause these other symptoms too? What do you guys think? Thanks!
 
Reply With Quote
  #2  
Old 04-19-2014, 04:22 PM
Thread Starter
Join Date: Mar 2014
Location: Monmouth, Maine
Posts: 7
Default

Also, I did a quick search on the web, and I found this out:
"One of the most noticeable symptoms of a faulty speed sensor is the odometer or speedometer of the vehicle not working. In some cases, if the speed sensor is damaged, cruise control will also not work. Symptoms may also present themselves within the transmission, and the vehicle may be rough or hesitate when trying to shift gears. The transmission may also jump gears. Some other symptoms can include the vehicle rumbling or not idling correctly. It may also burn more fuel than usual, and it may suddenly lose power."

- Source: Symptoms of a Faulty Speed Sensor and Replacement Instructions - AutoRepair.Answers.com

I am having ALL those symptoms. So I am going to go ahead and change the VSS, and see how the car runs after that.
 
Reply With Quote
  #3  
Old 04-20-2014, 08:33 AM
homey's Avatar
Newest Of Newbies
Join Date: Feb 2010
Posts: 27
Default

Its an easy fix and probably your issue. Just do the swap over something that you can find that little pin when you drop it. Its just two screws but I dropped the little coupler pin. I bought a cheapo off ebay and it worked for a year and was still going when I sold the car. Next one I replaced I left the coupler in it and just swapped the head. I compared the old and new, the pin stays in the unit and they were the same size. Dont drop the screws and you will be out fast.

Probably just the vss but dont panic yet if it doesnt fix it. Pull the codes from the tcu.Do give the repair a priority because it is not good for the transmission to be run with faulty controls. Ask me how much a transmission rebuild costs on a 90 accord. I know Good luck!
 

Last edited by homey; 04-20-2014 at 09:05 AM.
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
lashlecf
General Tech Help
6
05-12-2008 12:18 PM
sfcool
General Tech Help
6
11-02-2007 11:42 AM
Sliom001
Engine & Internal
8
09-24-2007 10:56 AM
ukbuckstop
General Tech Help
4
05-02-2007 09:56 PM
PJ_STYLES_95AccordEx
General Tech Help
1
08-09-2006 10:51 PM


Thread Tools
Search this Thread
Quick Reply: Vehicle Speed Sensor Symptoms


Advertising

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.