Suspension Talk about your suspension within.

97, new springs

  #1  
Old 06-05-2013, 01:19 AM
Thread Starter
Join Date: Oct 2011
Posts: 9
Default 97, new springs

Installed new Skunk2 2" springs, Truhart struts, all new mounts and bushings. After a day of driving, the front struts do not sit centered in the mounts, they tilt to the inside. Everything is tight and new. I can hear the strut piston rod making contact with the mount. I also used SPC adjustable upper ball joints. Any ideas or suggestions?
 
  #2  
Old 06-05-2013, 03:53 PM
hondafreak91c's Avatar
Senior Member
Join Date: Aug 2009
Location: Chino Hills, CA 91709
Posts: 412
Default

So the springs are not sitting on the upper and lower spring perches properly? Take some pics so we know what you mean.
 
  #3  
Old 06-06-2013, 02:31 PM
Thread Starter
Join Date: Oct 2011
Posts: 9
Default

 
  #4  
Old 06-06-2013, 02:38 PM
Thread Starter
Join Date: Oct 2011
Posts: 9
Default

I'm puzzled. New urethane isolators, everything is new. Assembled everything and install went smooth. But after one day, the pic shows my problem.
 
  #5  
Old 06-06-2013, 02:42 PM
Thread Starter
Join Date: Oct 2011
Posts: 9
Default

New wheels coming in a couple of days. While I have it up and the wheels off I will see if I can spot anything inside the mount
 
  #6  
Old 06-06-2013, 03:09 PM
hondafreak91c's Avatar
Senior Member
Join Date: Aug 2009
Location: Chino Hills, CA 91709
Posts: 412
Default

I can't see your picture. Upload it to photobucket or another photo sharing site, and post the [IMG][/IMG] link.
 
  #7  
Old 06-06-2013, 04:09 PM
Thread Starter
Join Date: Oct 2011
Posts: 9
Default

 
Attached Thumbnails 97, new springs-th_securedownload.jpg  
  #8  
Old 06-06-2013, 09:39 PM
Member
Join Date: Jan 2013
Location: Olympia, WA
Posts: 185
Default

hooo boy.
It's almost as if the top bolt weren't torqued all the way down, that's downright odd
 
  #9  
Old 06-06-2013, 09:59 PM
Thread Starter
Join Date: Oct 2011
Posts: 9
Default

New to me. Wonder if I was sent the wrong bushing kit or the bushing washer bent came down the shaft. Everything was/ is tight. I'll get a flashlight in there when I get it in the air
 
  #10  
Old 06-07-2013, 02:06 AM
Member
Join Date: Jan 2013
Location: Olympia, WA
Posts: 185
Default

That was my other guess. The EX/LX and the V6 all have different spring rates from the DX, but I didn't think they had different shock bodies or bushings.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
iskate604
Appearance
2
09-08-2013 07:29 AM
NickPJ
PRIVATE For Sale / Trade Classifieds
2
04-22-2010 02:02 PM
Cody Is Cool
General Tech Help
12
04-13-2007 04:09 PM
03Sleeper
Suspension
20
04-08-2007 04:43 AM
Newdude
Suspension
4
02-04-2006 05:53 PM


Thread Tools
Search this Thread
Quick Reply: 97, new springs


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.