Engine & Internal Chat about beefing up your engine's insides here.

Power Steering Pump Whine

  #1  
Old 03-07-2009, 08:11 PM
Thread Starter
Join Date: Feb 2009
Location: FL and NY
Posts: 16
Default Power Steering Pump Whine

I just replaced the bearing seal on my 98 accord 4-Banger engine. This is the bearing/ seal right behind the pulley. I reinstalled the pump and topped off the system with the proper fluid. I had the fron end up in the air and started the engine. The PS pump made some sucking noises as it began to run (sucking the air out of the feeding hose). I ran the wheels left and right to the stops about 8-10 times. No more leaks, but now it sounds like the pump is whining a little bit. Not so much when driving, but definately a lot if you turn the wheels when I am slow... like pulling into a parking spot. There arent really any bubbles in the resevoir and everything else seems normal.

Does it sound like there may still be some air in the system? Could I have tightend the pulley a little too much? Any ideas please let me know.

Thanks Everyone!
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
WordFliesNverted
General Tech Help
4
07-29-2014 04:29 PM
Hondarious
General Tech Help
2
11-07-2012 03:37 PM
TrinDawg38
General Tech Help
3
03-21-2012 05:58 PM
one54ton
General Tech Help
3
11-28-2011 05:04 PM
dkchatterton
General Tech Help
3
11-06-2007 02:48 PM


Thread Tools
Search this Thread
Quick Reply: Power Steering Pump Whine


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.