Engine & Internal Chat about beefing up your engine's insides here.

Problems after Tinming belt and waterpump change.

  #1  
Old 03-03-2016, 02:16 PM
Thread Starter
Join Date: Dec 2011
Posts: 9
Default Problems after Tinming belt and waterpump change.

I've got a 94 Accord LX manual, Just had timing belt , water pump, balancer belt and tensioners all changed at shop in town. Picked up this morning and drove to work about 40 miles. But it sounds like it is got an exhaust leak or something really load roaring. And seems like it has lost some power. Any Ideas before I call the shop that did the work back?
 
  #2  
Old 03-03-2016, 08:42 PM
JimBlake's Avatar
Super Moderator
Join Date: May 2006
Location: Wisconsin
Posts: 17,366
Default

They should not have had any reason to take the exhaust apart. I'd go straight back to the shop so they have less opportunity to claim that you ran over something in the road.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
mark95
General Tech Help
12
01-22-2015 09:34 PM
KincaidChance
General Tech Help
4
05-03-2011 01:13 AM
jmccalip
Engine & Internal
3
04-21-2008 10:39 AM
RoKnAzn
Engine & Internal
25
03-28-2007 12:30 PM
Lance Link
General Tech Help
10
02-06-2007 04:17 PM


Thread Tools
Search this Thread
Quick Reply: Problems after Tinming belt and waterpump change.


Advertising

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.