General Tech Help Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

help!!!!!!!speedometer not working

  #21  
Old 07-05-2009, 03:16 PM
TexasHonda's Avatar
Super Moderator : And A Texan
Join Date: Feb 2007
Location: Katy, TX
Posts: 9,651
Default

If you have a CEL, what is the code expressed? Check at autozone for a free read.

If the code is for VSS, then your installation may have been faulty. Did you install the tiny mechanical link between the drive and the VSS? W/o this link the VSS does not turn and generate a signal.

good luck
 
  #23  
Old 07-05-2009, 08:42 PM
TexasHonda's Avatar
Super Moderator : And A Texan
Join Date: Feb 2007
Location: Katy, TX
Posts: 9,651
Default

What was code; P???? Is it a state secret?

VSS fault is either VSS, wiring, or connector. A little diagnostics will reveal which.

regards
 
  #24  
Old 07-06-2009, 07:56 AM
JimBlake's Avatar
Super Moderator
Join Date: May 2006
Location: Wisconsin
Posts: 17,421
Default

And just to add some confusion, on the 95 Accord (original poster) the VSS drives the speedometer.

On a 98 Accord, the VSS signal goes to the ECU. Then the ECU controls the speedometer.
 
  #25  
Old 01-10-2018, 11:04 AM
Join Date: Jan 2018
Posts: 1
Default Cluster not working

Originally Posted by 00AccordLX5spd View Post
Does the entire cluster not work (i.e. tach, speedometer, gas gauge, temp gauge) or is it just the speedometer?
As Jimblake said if the cruise control works it is not the VSS.
Entire cluster isn't working on mine all the lights come on but none of the needles are moving
 
  #26  
Old 01-10-2018, 12:42 PM
JimBlake's Avatar
Super Moderator
Join Date: May 2006
Location: Wisconsin
Posts: 17,421
Default

An easy thing to check is loose or flaky connections where the wiring harness plugs into the cluster.

Beyond that, we need the year, model, engine, etc. There's already a couple different cars in this thread, so maybe it'll be better if you start a new thread.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
hffej54
General Tech Help
6
03-14-2009 06:36 PM
1joker069
General Tech Help
3
02-12-2009 03:16 PM
accordEX99
General Tech Help
0
11-03-2008 02:22 AM
sebastian
General Tech Help
1
01-09-2008 12:10 AM
cclc31
General Tech Help
3
10-25-2005 09:27 PM


Thread Tools
Search this Thread
Quick Reply: help!!!!!!!speedometer not working


Advertising

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.