General Tech Help Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

P0420, Accord 2005, 3.0L, 215k+ Miles

  #1  
Old 09-11-2012, 10:10 AM
Thread Starter
Join Date: Sep 2012
Posts: 2
Default P0420, Accord 2005, 3.0L, 215k+ Miles

Hello!

I have a 2005 Accord, 3.0L, Automatic Transmission with over 215,000 miles. About three weeks ago the Check Engine Light (CEL) came on. This perplexed me because I was cruising down a backroad at 60mph not doing anything crazy.

I went to Autozone and the guy said it was bad gas after he used the scanner and the code P0420 came up. The Autozone guy also recommended using STP Fuel Injector Cleaner. I bought two STP Fuel Injector Cleaner and immediately emptied one into the gas tank. Within 15 miles the CEL went out. After two or three days the CEL light came back in.

Gassing up the car I used premium octane and used an STP Fuel Injector Cleaner. The CEL went out after 6 miles.

A week went by and I gassed up the car again using 87 octane. The CEL came in.

Another week went by and I gassed up the car again using 93 octane (or whatever was highest), no STP Fuel Injector Cleaner, and after about 56 miles the CEL light went out.

I have the Honda Accord Service Manual 2003-2006. Based upon no other codes for the Oxygen sensors I've diagnosed the problem to be the TWC (Three Way Catalytic converter).

Is my diagnosis of the TWC correct? The replacement of the TWC looks straight forward but the burn in of the TWC does not. Does anyone follow the TWC burn in steps in the Honda Accord Service Manual or do most people simply replace and drive? Am I correct in not regarding the Oxygen sensors since there were no codes for them?

thanks if you can help.

LionZoomZoom
 
  #2  
Old 09-11-2012, 10:26 AM
Member
Join Date: Aug 2012
Location: Winston Salem, NC
Posts: 84
Default

the first thing that usually trips the CEL is the ox sensor. and if you added a fuel injector cleaner and the CEL light went out... could be the ox sensor read the mixture as correct as the fuel cleaner was burning.. then when it was all used up.. it came back on

Replace the ox sensor... besides.. they can get you better fuel mileage vs old. ( nomally they will go bad, and default to standard Mapping set in the ECU and burn more fuel cause they can't see varibles)

Brian B
 
  #3  
Old 09-11-2012, 03:07 PM
Member
Join Date: Jul 2012
Posts: 132
Default

sounds like your cat is dying, common on the 1998+ accords.

check out this vid:

 
  #4  
Old 09-11-2012, 04:04 PM
redbull-1's Avatar
Super Moderator
Join Date: Oct 2010
Location: United States
Posts: 6,595
Default

It probably is the cat needing replacement. P0420 on your 2005 Accord V6 is the rear warm up three way cat (TWC) (Bank 1).
 
Attached Thumbnails P0420, Accord 2005, 3.0L, 215k+ Miles-v6-cats.jpg  
  #5  
Old 09-11-2012, 07:08 PM
Thread Starter
Join Date: Sep 2012
Posts: 2
Default

Thank you for all the information! Redbull-1, I found the diagram especially helpful in clearing up what people meant by three catalytic converters. Doctorbee, I will try the pure lacquer this week and will post how things turn out. I did not want to rent or borrow a tool to replace the Ox sensor.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
rockhoundrob
General Tech Help
4
01-17-2014 06:35 AM
Drpepper
General Tech Help
12
09-03-2012 11:20 PM
bkraz
General Tech Help
2
04-01-2010 12:54 PM
Barry92LX
Engine & Internal
7
02-06-2010 03:49 AM
05HondaAccord
General Tech Help
2
05-05-2008 11:24 PM


Thread Tools
Search this Thread
Quick Reply: P0420, Accord 2005, 3.0L, 215k+ Miles


Advertising

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.