Off Topic A place for you car junkies to boldly post off topic.

Plugs

  #1  
Old 03-10-2018, 12:25 AM
TexomaAccord's Avatar
Senior Member
Thread Starter
Join Date: Mar 2014
Location: Texoma, Texas
Posts: 372
Default Plugs

Do my plugs look okay?
 
  #2  
Old 03-10-2018, 06:48 AM
JimBlake's Avatar
Super Moderator
Join Date: May 2006
Location: Wisconsin
Posts: 17,371
Default

You could probably use them again if you cleaned them up a bit. Try some JB Weld to repair the insulating collar around the (+) post. That'll stand up to higher temperature than silicone.
 
  #3  
Old 03-11-2018, 07:41 AM
TexomaAccord's Avatar
Senior Member
Thread Starter
Join Date: Mar 2014
Location: Texoma, Texas
Posts: 372
Default

10 yr old acdelco plugs from a mercruiser
I wish there was a boat category. That's what I do all day
 
  #4  
Old 03-11-2018, 02:09 PM
Been Around A Long Time Member
Join Date: Feb 2016
Location: Kimball MI
Posts: 910
Default

Originally Posted by TexomaAccord View Post
10 yr old acdelco plugs from a mercruiser
I wish there was a boat category. That's what I do all day
Chevy V6?
 
  #5  
Old 03-11-2018, 05:44 PM
keep_hope_alive's Avatar
Super Moderator
Join Date: Dec 2009
Location: Quad Cities, IL
Posts: 3,207
Default

Originally Posted by The Toecutter View Post
Chevy V6?
Mercury V8, usually around 300cu.in. is my guess
 
  #6  
Old 03-17-2018, 09:11 AM
TexomaAccord's Avatar
Senior Member
Thread Starter
Join Date: Mar 2014
Location: Texoma, Texas
Posts: 372
Default

Hey @keep_hope_alive -- that car audio build log link in your sig, no workie

and its a mercruiser v8 (basically a chevy)
 
  #7  
Old 03-21-2018, 10:45 PM
Corvair's Avatar
Member
Join Date: Aug 2014
Location: Southern Minnesota
Posts: 198
Default

How did it run when they were in and how many miles?

Also my Accord has about 105,000 miles and still has the original plugs. How long have people been getting on plugs. It's the 2.4 on a 2014.
 
  #8  
Old 03-22-2018, 04:44 AM
TexomaAccord's Avatar
Senior Member
Thread Starter
Join Date: Mar 2014
Location: Texoma, Texas
Posts: 372
Default

they are from a striper guide fishing boat. ran them for over 10 years
 
  #9  
Old 03-22-2018, 03:41 PM
Been Around A Long Time Member
Join Date: Feb 2016
Location: Kimball MI
Posts: 910
Default

Originally Posted by Corvair View Post
How did it run when they were in and how many miles?

Also my Accord has about 105,000 miles and still has the original plugs. How long have people been getting on plugs. It's the 2.4 on a 2014.
On my 97 S-10 the plugs in it were ran up to 149K when I changed them and the original plug wires. It came stock with AC Delco iridium plugs. Those are supposed to go 100K and then get changed. Those in my truck still looked good even at that mileage.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
accord4sroy
Engine & Internal
11
03-21-2006 12:41 PM
LinX
Engine & Internal
2
02-27-2006 04:01 AM
marbro
Engine & Internal
31
02-18-2006 12:17 AM
hotrod20
General Tech Help
13
12-04-2005 11:04 PM
TheNewGuy
General Tech Help
2
07-01-2005 07:54 PM


Thread Tools
Search this Thread
Quick Reply: Plugs


Advertising

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.