Engine & Internal Chat about beefing up your engine's insides here.

My Coupe Has Gone Problematic On Me

  #1  
Old 05-28-2013, 01:06 AM
Junior Member
Thread Starter
Join Date: Apr 2013
Location: Miami, FL
Posts: 41
Default My Coupe Has Gone Problematic On Me

Ok, from start to finish.... bare with me.

I bought this 94 coupe DX 5speed F22B1 Vtec about a month ago....title says DX....got her cheap and driving pretty good...under the hood was clean, since it was new to me, I replaced parts that I felt were not working so well, like the alternator and power steering pump and almost all the coolant hoses and thermostat, and the standard tune up....

After a week, the timing belt snapped on me, had the block and head tested at a machine shop and they said it was fine, got the block cleaned up and the head remachined, new gaskets all around....got everything up and running within a week. (doing this in my backyard) the timing was off and no vtec so I re adjusted to the proper timing and she ran great but had some trouble starting but she started eventually and I regained VTEC functions.

Everything has Ben great for about 2 weeks..about 2 days ago, my car sometimes tries to bogg out, idle fluxes up and down. Now I'm at a limited rev at around 4,500 rmps. I feel and hear Vtec for the last few hundred rpms. I can't go passed 45k in gear or neutral. Drives Perfectly fine other than limited rev.

I pulled codes from the computer. (this is when I found put its an ODB computer) I couldn't find a port for my odb2 reader so I had to jump the input on the hanging cable. I got 3 of them (ill update later with the actual codes) vss was out so I replaced that yesterday, now my gauge is erratic, never showing the correct speed. I noticed some non factory wiring under the hood on the vtec solenoid and and some wires running to the fans. (will update later with pics for reference) The Dizzy seems suspect as well.

I dont know if the 94 coupes came with an f22b1 vtec motor or even a 5speed!

I think I bought a hackjob of a swap.

I dont think the dizzy is a b1 dizzy, I don't think its running the correct ECM, so I can have a lot of fuel mapping problems which can explain the limited rev. The wiring is not factory but its wired right as far as vtec, I feel and hear it.

ill update with pics, part numbers and cel codes. Any help would be greatly appreciated, I'm building this car and want it as good as possible by June 2, that's when its going for paint and vossen fittmwnt. I've got a lot of plans for this car and have a lot of money invested already and a set aside budget for paint and exterior work.

DOES THIS MODEL COME WITH THIS MOTOR OPTION? DX 5SPEED VTEC?

WHAT THE HELL IS STOPPING MY GEARS SHORT?

DO I NEED TO CHANGE EVERYTHING TO B1 PARTS IF THEY END UP BEING B2 PARTS?

These are my problems and this will be a legacy, you guys are the accord experienced gurus, any push in the right direction will be greatly appreciated.

sorry for the long Post, you'll need some insight if you decide to help.

Thanks even
 
  #2  
Old 05-30-2013, 06:38 PM
poorman212's Avatar
Super Moderator
Join Date: May 2010
Location: Youngsville, NC
Posts: 11,819
Default

Until we know the codes, it is all a guess.

You can check the VIN and then check the stamping on the block, someone might have changed the engine. So check both.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
wenmang
General Tech Help
9
11-21-2013 02:30 PM
Tony1M
Off Topic
24
08-09-2008 09:32 PM
powerpeecee
Headers, Intake, & Exhaust
0
06-06-2008 07:17 PM
sleep depervation
General Tech Help
14
05-08-2006 10:41 AM
lightshow
New Member Area
13
03-20-2006 06:41 AM


Thread Tools
Search this Thread
Quick Reply: My Coupe Has Gone Problematic On Me


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.