Engine & Internal Chat about beefing up your engine's insides here.

Speedometer

  #1  
Old 09-17-2009, 06:06 PM
Junior Member
Thread Starter
Join Date: Sep 2009
Location: Dawsonville GA
Posts: 42
Question Speedometer

my speedometer doesnt work, it floats, and sometimes will work, i was told it was because my tires were the wrong size, but that wouldnt even effect it. (plus the tires are the right size), and i was told there was a plug in the transmission that might be loose, and it could be effecting it. it baffles me.

i drive a 1994 accord ex
A/T
F22B1

Please Help
 
  #2  
Old 09-21-2009, 08:48 AM
JimBlake's Avatar
Super Moderator
Join Date: May 2006
Location: Wisconsin
Posts: 17,456
Default

Vehicle Speed Sensor (VSS) is located on top of the tranny, in back above axle line. Kinda below the throttle body.

That thing provides the signal to the speedometer. Look for loose/dirty/corroded wiring plugs. It's possible the sensor is getting flaky. Normally that would produce a check-engine light... ?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
cochre
General Tech Help
8
05-10-2012 11:58 AM
UnitedAuto
General Tech Help
17
04-18-2011 10:44 PM
darryltravis
General Tech Help
6
04-25-2006 01:26 AM
cclc31
General Tech Help
3
10-25-2005 09:27 PM
cbriley3
General Tech Help
2
10-23-2005 11:04 PM


Thread Tools
Search this Thread
Quick Reply: Speedometer


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.