2007 heat broken - Honda Accord Forum - Honda Accord Enthusiast Forums

New Member Area Are you new? WELCOME! Check in, tell us about yourself and your ride.

2007 heat broken

  #1  
Old 12-09-2018, 06:46 PM
Thread Starter
Join Date: Dec 2018
Posts: 4
Default 2007 heat broken

Yesterday my heat,ac and blower suddenly stopped working . My dash is dark and the outside temp indicator is not displaying (guessing its related somehow)

Looking for suggestions on diagnostics to do and possible dyi fixes

thanks
 
  #2  
Old 12-09-2018, 07:03 PM
Senior Member
Join Date: Jun 2017
Posts: 378
Default

Where you working on something that caused it? Disconnect the battery for 15 mins then reconnect. Check fuses 21, 23, 30 in the cabin fuse box located by the drivers left
 
  #3  
Old 12-09-2018, 07:24 PM
Thread Starter
Join Date: Dec 2018
Posts: 4
Default 2007 heat broken

Thanks for the recommended fix - I wasn’t working on the car - the heat worked earlier in the day and then just stopped when I went to use later .
 
  #4  
Old 12-10-2018, 07:28 PM
Been Around A Long Time Member
Join Date: Feb 2016
Location: Kimball MI
Posts: 873
Default

Originally Posted by Donna Bailey View Post
Yesterday my heat,ac and blower suddenly stopped working . My dash is dark and the outside temp indicator is not displaying (guessing its related somehow)

Looking for suggestions on diagnostics to do and possible dyi fixes

thanks
Welcome. It might be worth having a look in the Audio/Visual form in the General forums, as someone might have had a similar problem.
 
  #5  
Old 12-11-2018, 07:48 PM
Thread Starter
Join Date: Dec 2018
Posts: 4
Default 2007 Accord heat broken- new information

I wanted to add that besides my heater being broken, not showing up on my dash - the radio shows up but the defrost, heat and AC indicator does not show up.
My seater heaters do not work and the light does not work
The outside temp usually shows up on my dash - now it reads ——

Hoping this additional info helps
 
  #6  
Old 12-15-2018, 06:42 AM
poorman212's Avatar
Super Moderator
Join Date: May 2010
Location: Youngsville, NC
Posts: 11,817
Default

Originally Posted by Seanjordan20 View Post
Check fuses 21, 23, 30 in the cabin fuse box located by the drivers left
^ x2. I agree and would start with checking the fuse(s).

 
  #7  
Old 12-15-2018, 09:59 AM
Thread Starter
Join Date: Dec 2018
Posts: 4
Default

It was an interior fuse - fixed
 
  #8  
Old 12-16-2018, 10:45 AM
poorman212's Avatar
Super Moderator
Join Date: May 2010
Location: Youngsville, NC
Posts: 11,817
Default

Glad you found it but the question is what blew the fuse? They don't blow just becasue, something happened or isn't "right" which cause the fuse to blow.

Which one was it?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
p.p.cartier
General Tech Help
1
10-01-2017 06:51 PM
rick_esco
General Tech Help
5
10-26-2014 06:28 PM
skijour
General Tech Help
2
08-15-2012 08:31 PM
Cessna172
General Tech Help
5
11-05-2010 01:22 PM
pgopalak
General Tech Help
3
12-17-2004 03:30 PM


Thread Tools
Search this Thread
Quick Reply: 2007 heat broken


Advertising

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.