New Member Area Are you new? WELCOME! Check in, tell us about yourself and your ride.

Please Help! Engine acting strange!

  #1  
Old 01-26-2018, 04:50 PM
lev
lev is offline
Thread Starter
Join Date: Jan 2018
Posts: 1
Default Please Help! Engine acting strange!

Hi, I have a 2012 Honda Accord with about 100,000 miles. For about 2 weeks now, anytime I am on the freeway or the RPMs are above 2000 there has been pretty heavy vibration in the gas peddle and the engine is very loud and sounds like a go-kart. Any ideas? Ultimately the car has no problems driving but it feels like it is just around the corner from a major issue. Any ideas of what it could be would be much appreciated. Thank you!

Josh
 
  #2  
Old 01-27-2018, 08:21 AM
TexasHonda's Avatar
Super Moderator : And A Texan
Join Date: Feb 2007
Location: Katy, TX
Posts: 9,649
Default

Heavy vibration could be failed motor mount or worn CV axle.

Noise description is too vague to provide any help.

good luck
 
  #3  
Old 02-15-2018, 03:57 PM
Join Date: Feb 2018
Posts: 8
Default

check your motor mounts especially the rear mount
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
500$accord
General Tech Help
5
11-14-2011 05:09 PM
Ronracer
General Tech Help
2
04-08-2010 09:23 AM
Drkmstr104
General Tech Help
5
08-26-2009 03:59 AM
drummer1279
General Tech Help
17
08-18-2006 12:21 AM


Thread Tools
Search this Thread
Quick Reply: Please Help! Engine acting strange!


Advertising

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.