Suspension Talk about your suspension within.

1999 156k mi, doesn't handle like it used to

  #1  
Old 07-04-2013, 03:34 PM
GeL
GeL is offline
Thread Starter
Join Date: Jul 2013
Posts: 2
Default 1999 156k mi, doesn't handle like it used to

My 1999 Accord has 156k mi and the original struts and shocks. They appear to be in good shape. However, the car doesn't handle the road like it used to. Would replacing the struts help? If so, should I also replace the shocks?
Thanks
 
  #2  
Old 07-04-2013, 08:10 PM
shipo's Avatar
Super Moderator
Join Date: Aug 2012
Location: Southern New Hampshire
Posts: 2,444
Default

Are the shocks and/or struts leaking oil? Does the car "bounce" when you hit a bump?

If none of the above then I'm thinking it might just be your tires.
 
  #3  
Old 07-06-2013, 12:47 PM
GeL
GeL is offline
Thread Starter
Join Date: Jul 2013
Posts: 2
Default 1999 156k mi, doesn't handle like it used to

No leaks or bouncing. The tires are relatively new, not cheap tires.

Thanks for the response.
 
  #4  
Old 07-06-2013, 01:12 PM
shipo's Avatar
Super Moderator
Join Date: Aug 2012
Location: Southern New Hampshire
Posts: 2,444
Default

Not all tires are created equal; some specialize in a smooth quiet ride, others specialize in razor sharp handling.

What tires are you running?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
kamiiko19
General Tech Help
12
12-17-2010 07:49 PM
fishin4fun
General Tech Help
9
07-20-2009 07:52 AM
spazz
General Tech Help
2
01-23-2008 07:19 PM
SandMan
Off Topic
4
09-22-2007 12:33 AM
EXV6
General Tech Help
3
07-27-2007 12:41 PM


Thread Tools
Search this Thread
Quick Reply: 1999 156k mi, doesn't handle like it used to


Advertising

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.